MiMI Plugin
User Guide
## CONTENTS

<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Overview</strong></td>
<td>1</td>
</tr>
<tr>
<td>About data sources</td>
<td>1</td>
</tr>
<tr>
<td>Workflow overview</td>
<td>2</td>
</tr>
<tr>
<td><strong>Installing Cytoscape and the MiMI Plugin</strong></td>
<td>2</td>
</tr>
<tr>
<td>Launching Cytoscape and the MiMI Plugin from the Web</td>
<td>3</td>
</tr>
<tr>
<td>Installing Cytoscape and the MiMI Plugin on your local computer</td>
<td>3</td>
</tr>
<tr>
<td><strong>Entering Gene Information</strong></td>
<td>5</td>
</tr>
<tr>
<td>Option 1: Load a file containing gene symbols</td>
<td>5</td>
</tr>
<tr>
<td>Option 2: Enter a list of gene symbols</td>
<td>6</td>
</tr>
<tr>
<td>Additional options</td>
<td>7</td>
</tr>
<tr>
<td><strong>Choosing Attributes for Display in the Data Panel</strong></td>
<td>8</td>
</tr>
<tr>
<td>Choosing attributes provided through MiMI</td>
<td>9</td>
</tr>
<tr>
<td>Importing your own attributes</td>
<td>10</td>
</tr>
<tr>
<td>Rearranging attributes in the Data Panel</td>
<td>16</td>
</tr>
<tr>
<td><strong>Navigating a Network</strong></td>
<td>17</td>
</tr>
<tr>
<td>Navigating among networks</td>
<td>17</td>
</tr>
<tr>
<td>Navigating within a network</td>
<td>18</td>
</tr>
<tr>
<td>Locating genes or gene interactions within a network by searching</td>
<td>19</td>
</tr>
<tr>
<td>Locating genes or interactions using the Data Panel</td>
<td>23</td>
</tr>
<tr>
<td><strong>Selecting Genes and Gene Interactions</strong></td>
<td>24</td>
</tr>
<tr>
<td>For more information</td>
<td>26</td>
</tr>
<tr>
<td><strong>Accessing Gene and Gene Interaction Information</strong></td>
<td>26</td>
</tr>
<tr>
<td>Linking to gene literature through Gene2MeSH</td>
<td>26</td>
</tr>
<tr>
<td>Linking to detailed information on MiMI Web</td>
<td>26</td>
</tr>
<tr>
<td>Linking to gene interaction literature through BioNLP</td>
<td>28</td>
</tr>
<tr>
<td>Linking to other data sources</td>
<td>29</td>
</tr>
<tr>
<td><strong>Matching Pathway Graphs Using SAGA</strong></td>
<td>32</td>
</tr>
<tr>
<td><strong>Working with Networks</strong></td>
<td>35</td>
</tr>
<tr>
<td>Expanding a network on a gene node</td>
<td>35</td>
</tr>
<tr>
<td>Collapsing an expanded gene node</td>
<td>37</td>
</tr>
<tr>
<td>Destroying a network</td>
<td>37</td>
</tr>
</tbody>
</table>
Saving and Reopening a Session

- Saving a session
- Reopening a session

Using MiMI Plugin-Specific Features in Cytoscape

- Restoring the MiMI visual style
- Annotations
- Accessing the MiMI Plugin legend
- MiMI Plugin selection behavior
OVERVIEW

About data sources

The MiMI Plugin provides access to data in the MiMI database from within the Cytoscape bioinformatics network visualization tool. The MiMI database integrates molecular data from numerous protein-interaction databases, including:

- **BIND (Biomolecular Interaction Network Database)**

- **CCSB (Center for Cancer Systems Biology)**
  [http://ccsb.dfci.harvard.edu/web/www/ccsb](http://ccsb.dfci.harvard.edu/web/www/ccsb)

- **DIP (Database of Interacting Proteins)**
  [http://dip.doe-mbi.ucla.edu/dip/Main.cgi](http://dip.doe-mbi.ucla.edu/dip/Main.cgi)

- **GRID (General Repository for Interaction Datasets)**

- **HPRD (Human Protein Reference Database)**

- **IntAct**
  [http://www.ebi.ac.uk/intact/main.xhtml](http://www.ebi.ac.uk/intact/main.xhtml)

- **KEGG (Kyoto Encyclopedia of Genes and Genomes)**

- **MDC (Max Delbrück Center)**

- **MINT (Molecular INTeraction database)**
  [http://mint.bio.uniroma2.it/mint/Welcome.do](http://mint.bio.uniroma2.it/mint/Welcome.do)

- **PubMed**

- **Reactome**

Each of these data sources is updated on its own schedule. The MiMI Plugin reflects updates as they become available.

For information on additional data sources available through the MiMI Plugin, see the About MiMI page.
Workflow overview

With the MiMI Plugin for Cytoscape, you can visualize interactions between genes or proteins, and interactively explore the network of relationships among them. The basic steps in the workflow include:

1. **Enter a set of genes.** You can type in a list of genes or upload a file of gene symbols.

2. **Select gene and gene interaction attributes.** Choose which attributes to display in a table as you work with a visual network graph, including any attributes you import into Cytoscape.

3. Explore the visual network and table of attributes:
   - **Expand and collapse the network.**
   - Sort and filter data.
   - Visualize your data in a wide variety of network layouts provided by Cytoscape.
   - Use color, size, and other effects to visually reflect a set of attribute values.

4. Select genes or gene interactions to access more detailed information about them:
   - **Link out to additional information about selected objects.**
   - **Access summaries of abstracts** mined from the research literature through natural language processing (BioNLP) related to a selected gene interaction.
   - **Compare a part of your network to a database of known biological pathways.**

5. **Save your session and reopen it later.**

INSTALLING CYTOSCAPE AND THE MIMI PLUGIN

You can use the MiMI Plugin for Cytoscape in one of two ways:

- **By launching Cytoscape and the MiMI Plugin from MiMI Web.** With this method, you launch a temporary copy of Cytoscape and the MiMI Plugin from a Gene Details page after performing a search on MiMI Web. Use this method when you don’t have the administrative privileges to install software on your computer. You will not have access to other plugins when you use this method.

- **By installing Cytoscape and the MiMI Plugin on your local computer.** With this method, you can use other plugins that work with MiMI data, such as Shortest Path and MCODE.
Launching Cytoscape and the MiMI Plugin from the Web

To launch Cytoscape and the MiMI Plugin from MiMI Web:

2. On the Free Text Search or List Search tab, search for one or more genes. (For more information on searching in MiMI Web, click the Help tab.)
3. On a Search Results page, click a gene link.
4. On the Gene Details page, click the Cytoscape button near the bottom of the page.

After launching the Web version of Cytoscape, you can do anything described in this User Guide.

You can save your Cytoscape session on your local computer and reopen it at a later time after launching the application from MiMI Web again.

Installing Cytoscape and the MiMI Plugin on your local computer

1. Install Cytoscape on your computer. For more information, go to:
2. After Cytoscape is installed, start the application.
3. To install the MiMI Plugin, select Plugins → Manage Plugins from the Cytoscape menu.
4. Under **Available for Install**, click the + box to expand the **Network and Attribute I/O** group.
5. Find and click the most recent version of the MiMI Plugin.

![Plugin Manager](image)

6. Click **Install**.

7. When installation is complete, click **Close**.

A **MiMI Plugin** option is added to the Cytoscape **Plugins** menu.

**ENTERING GENE INFORMATION**

1. To begin a Cytoscape session with the MiMI Plugin, start Cytoscape.
2. Select **Plugins** → **MiMI Plugin** → **Query** from the Cytoscape menu.
3. Choose one of these methods to specify genes.

**Option 1: Load a file containing gene symbols**

Use when you have a large number of gene symbols. The file:

- Must be a text file.
- Must include a list of official gene symbols, one per line.
Example:

```
CP
HFE
SLC39A14
FTL
LCN2
TF
UGT1A1
NPC2
B4GALT1
PLD4
SGP11
EDG3
SOAT1
ABCA1
APOD
```

1. Click the **From File** tab.

2. Click **Load Gene File**...

3. Browse to the gene file and click **Open**.

4. Continue with **Additional options**.

**Option 2: Enter a list of gene symbols**

Use to do a query with a small number of gene symbols.

1. On the **Enter Gene Symbol(s)** tab, enter one or more gene symbols, separated by commas.
Additional options

1. Select an organism, molecule type, and/or data source, or use the defaults.

   **Note:** Selecting **All Data Sources** includes all of the other data sources listed in the dropdown, as well as additional data sources. For a complete list of data sources, see the [About MiMI](#) page.

Dialog box after loading a file containing gene symbols:

Dialog box after entering a list of gene symbols:

2. For **What to retrieve**, select one of the following options (examples show resulting networks for entering a list of the gene symbols CP, HFE, SLC39A14, and FTL):

   **Query genes + nearest neighbors**

   ![Example network diagram](image)

   26 nodes, 32 edges
Interactions among query genes (include at least 2 genes)

2 nodes, 1 edge

Query genes + neighbors’ neighbors

4,607 nodes, 28,221 edges

Nearest neighbors shared by more than one query genes (include at least 2 genes)

2 nodes, 1 edge

3. Click **Search**.

**CHOOSING ATTRIBUTES FOR DISPLAY IN THE DATA PANEL**

Attributes of genes (nodes) and gene interactions (edges) you have selected in the network appear in the Cytoscape Data Panel.
Choosing attributes provided through MiMI

To choose which attributes to view:

1. To choose attributes for gene nodes, click the Node Attribute Browser tab in the Data Panel; for gene interaction edges, click the Edge Attribute Browser tab.

2. Click the Select Attributes icon in the Data Panel toolbar.

3. Select the attributes you want displayed in the Data Panel.

   ![Select Attributes]

   **Note**: Other plugins used earlier in your Cytoscape session may leave behind attributes that don’t apply to MiMI Plugin data.

4. When you are done, click anywhere outside the list.
5. Select genes or gene interactions to view their attributes in the Data Panel (see “Selecting Genes and Gene Interactions”).

![Diagram of gene network]

**Importing your own attributes**

To add your own attributes to the Data Panel, you can import an attribute file. The file:

- Must be a text file or a Microsoft Excel 97-2003 workbook file (.xls).
- If a text file:
  - Attributes (columns) must be tab-separated.
  - Records (rows) must be on their own line.
- Attribute names (column headings) are optional.
- One column must be a key column (for example, Gene Symbol) to map to a key attribute in the existing network.
Excel example:

For information on other importing options, see “Import Attribute Table Files” in the Cytoscape User Manual.

To import attributes:

1. From the Cytoscape menu, select File → Import → Attribute from Table (Text/MS Excel)…
2. For **Attributes**, select **Node**, **Edge**, or **Network**, depending on the attributes you’re adding, and click **Select File(s)**.

3. Browse to your attribute file, and click **Open**. Attribute data is imported:
4. If your attribute file includes attribute names as column headings, select **Show Text File Import Options**, and then select **Transfer first line as attribute names**.

Select Import Options

Select Transfer option

First-row values become attribute names
If your attribute file does not include column headings for attribute names, name them by right-clicking the default column headings and entering a new attribute name.

5. To map your key column to the key attribute, first click **Show Mapping Options**, and then select the column from the **Primary Key** dropdown.
6. Select the corresponding key attribute in the existing network.

7. Click **Import** at the bottom of the dialog box.

8. To view your attributes in the Data Panel, click the **Select Attributes** icon in the Data Panel toolbar and select the attributes, which will appear in the panel when you select nodes and edges that have imported attributes associated with them.
Rearranging attributes in the Data Panel

To reorder attributes in the Data Panel, click an attribute column heading and drag it to a new location.

To sort by an attribute, click the attribute column heading; to sort in the reverse direction, click again.
NAVIGATING A NETWORK

Navigating among networks

To navigate among multiple open networks, use the **Network** tab in the Cytoscape Control Panel.

To view a network, click on its entry on the **Network** tab.

**Note:** The default network title is a list of the queried genes followed by the options you selected for the query. To edit a title, right-click the network entry and select **Edit Network Title**.

For more information about working with networks and the **Network** tab, see the *Cytoscape User Manual.*
Navigating within a network

To navigate within a network, use the network overview pane at the bottom of the Network tab in the Cytoscape Control Panel.

To view another part of the network, click on the shaded area in the network overview pane and drag it into place.

To adjust the view magnification, use the Zoom tools in the Cytoscape toolbar:

- **Zoom Out** and **Zoom In**.
- **Zoom Selected Region**. Make one or more selections using any Cytoscape methods, then click this tool to display the region that encompasses all of them.
- **Zoom Entire Network**.

For more information about zooming and using the network overview pane, see the Cytoscape User Manual.
Locating genes or gene interactions within a network by searching

You can locate and select a specific gene or gene interaction within a network by using the Search feature of Cytoscape. You can also use search to find a group of genes or interactions with common attribute values. Search is especially useful with large, complex networks.

Limitations of the Search feature in Cytoscape:

- For a successful match, the search term must match the entire attribute value. For example, the following Gene Description attributes do not match:
  - NADH dehydrogenase (ubiquinone) 1 beta subcomplex, 8, 19kDa
  - NADH dehydrogenase (ubiquinone) 1 beta subcomplex, 2, 8kDa

- For a successful match, the search term must match the attribute value from the start of the string—you cannot match a substring within an attribute value. For example, the search term **Lysine biosynthesis** does not match the following attribute value:
  - Citrate cycle (TCA cycle) [path:hsa00020]; Lysine biosynthesis [path:hsa00300]; D-Glutamine and D-glutamate metabolism [path:hsa00471]

- Search does not support logical operators, wildcards, or other advanced search features.

**Note:** For more flexible and powerful searching, including logical operators and wildcards, you can use the Enhanced Search plugin for Cytoscape. For more information, see the Analysis group of plugins on the Cytoscape Plugins page.

To search for genes or interactions:

1. Click **Configure search options** to the right of the Search box in the Cytoscape toolbar.
2. Set search options.

Select which attributes to list
Select the attribute to search by

Click Apply

3. Enter a search term in the **Search** box. As you type, matching attribute values appear in a dropdown list.
4. Select an item in the list to locate the node or edge. Cytoscape zooms to the item and selects it.

**Note:** Using Search to select a gene interaction also selects the connected genes.

**Example: Locating genes on the same chromosome (chromosome 13)**

1. In the **Configure Search Options** dialog, select the **Chromosome** attribute for genes (nodes).
2. Type in the **Search** box and select **13** (with 6 matching genes).

![Search box with selected 13 genes](image)

3. The 6 genes are selected.

![Selected genes](image)

4. The Data Panel displays attributes for the selected genes.

```
<table>
<thead>
<tr>
<th>ID</th>
<th>Chromosome</th>
<th>Gene Name</th>
<th>Component</th>
</tr>
</thead>
<tbody>
<tr>
<td>8428</td>
<td>13</td>
<td>STK24</td>
<td>cytoplasm [GO:0005737]</td>
</tr>
<tr>
<td>8803</td>
<td>13</td>
<td>SUCLA2</td>
<td>mitochondrion [GO:0005739]</td>
</tr>
<tr>
<td>1045</td>
<td>13</td>
<td>CDX2</td>
<td>condensed nuclear chromosome</td>
</tr>
<tr>
<td>1282</td>
<td>13</td>
<td>COL4A1</td>
<td>basement membrane [GO:000561]</td>
</tr>
<tr>
<td>10562</td>
<td>13</td>
<td>OLFM4</td>
<td>extracellular region [GO:0005575]</td>
</tr>
<tr>
<td>1284</td>
<td>13</td>
<td>COL4A2</td>
<td>collagen [GO:0005581]; collagen</td>
</tr>
</tbody>
</table>
```
Locating genes or interactions using the Data Panel

You can locate specific gene nodes and interaction edges in the network view by selecting their attributes in the Data Panel.

1. Click the **Node Attribute Browser** or **Edge Attribute Browser** tab in the Data Panel.

2. Select attribute rows for the nodes or edges you want to locate.
   - Click on a single row to highlight a single gene or interaction.
   - Use Ctrl-click to select multiple discontiguous rows.
   - Use Shift-click to select a range of contiguous rows.

3. The corresponding genes or interactions are highlighted in green in the network view.
**Note:** This procedure helps you visually identify individual nodes or edges from among those already selected in the network view, but does not create an actionable subset. Cytoscape functions will continue to operate on all selected nodes or edges, not just those you have located using this procedure.

**SELECTING GENES AND GENE INTERACTIONS**

Use Cytoscape methods to select nodes (representing genes) and edges (representing interactions between genes).

### Selecting a single gene

Click the gene node.

A selected node appears in yellow.

### Selecting a single gene interaction

Click and drag a rectangle around any segment of the gene interaction edge, then release the left mouse button.

A selected edge appears in red.
Selecting multiple genes and/or gene interaction edges

Hold down the **Shift** key while clicking on nodes and/or edges and/or while dragging rectangles around them.

Selecting genes and gene interactions within an area

Click and drag a rectangle around any area of the network to select the nodes and edges within that area.

Selecting any part of a node or edge selects the entire node or edge.
For more information
For detailed information on selecting nodes and edges in a network, see the Cytoscape User Manual.

ACCESSING GENE AND GENE INTERACTION INFORMATION

In addition to viewing gene and gene interaction attribute values in the Cytoscape Data Panel, you can link to related information in additional data sources.

Linking to gene literature through Gene2MeSH

To access PubMed articles related to a gene through matching MeSH subject headings:

1. Right-click a gene node, and select MiMI Plugin → LinkOut NCIBI → Gene2Mesh.
2. The Gene2MeSH page for the selected gene appears in a new browser window or tab.

For more information about using Gene2MeSH, see the Gene2MeSH About page.

Linking to detailed information on MiMI Web

To access more detailed information about a gene or gene interaction:

1. Right-click a gene node or gene interaction edge, and select MiMI Plugin → LinkOut NCIBI → MiMIWeb.
2. The Details page in MiMI Web for the selected gene or interaction appears in a new browser window or tab.
For a gene:
For an interaction:

For more information on using MiMI Web, see the MiMI Help and Support page.

**Linking to gene interaction literature through BioNLP**

To access summaries of abstracts related to a gene interaction through BioNLP (Natural Language Processing of Biology text):

1. Right-click a gene interaction edge, and select **MiMI Plugin → BioNLP**.
2. A list of matching sentences appears.

![Image of linked sentences]

**Click to view the Gene Details page on MiMI Web**

**Click to view the PubMed abstract of an article**

### Linking to other data sources

You can access gene and gene interaction information from numerous external data sources using LinkOut menus in Cytoscape.

#### Linking to external sources from the network view

1. In the Cytoscape network view, right-click a gene node or interaction edge.
2. Move to the **LinkOut** menu.
3. Choose a data source from the LinkOut submenus.
For example, selecting LinkOut $\rightarrow$ Entrez $\rightarrow$ Gene:

```
+----------------+----------------+----------------+----------------+
|     HFE        |     TFRC       |     HNF1A      |
+----------------+----------------+----------------+
| 3077           |                |                |
| Visual Mapping Bypass | Use Web Services |               |
| LinkOut         | Entrez         |                |
| MIMI Plugin     | Model Organism DB |       |
| MetScape        | Array Express  |                |
|                | Ensembl Gene View |       |
|                | KEGG           |                |
+----------------+----------------+----------------+
| Database       |                |                |
| Entrez         |                |                |
| Interaction Databases | iHOP         |       |
| Other Biological DB | Ontology     |       |
| Ontology       | EBI Tools      |                |
| Uniprot        |                |                |
| Search Engines |                |                |
+----------------+----------------+----------------+
| Entrez         |                |                |
| Gene           |                |                |
| Protein        |                |                |
| OMIM           |                |                |
| Nucleotide     |                |                |
+----------------+----------------+----------------+
```

results in the following Entrez Gene page for the selected gene:
Note: The external data sources available for genes differ from those available for gene interactions.

Linking to external sources from the Data Panel

When linking to external data sources from the Cytoscape Data Panel, you can link to the external source using a specific attribute value. However, not all attribute values are appropriate for all data sources.

1. In the Cytoscape Data Panel, right-click on the value in the attribute column in the row for the gene or interaction of interest.

2. Move to the Search...on the web menu, and choose an appropriate data source from the submenus.
For example, right-clicking the value **hsa:3077** in the **Kegg gene** attribute column and selecting **KEGG → All Species (use KEGG ID)** results in the following KEGG page for the corresponding gene:

**MATCHING PATHWAY GRAPHS USING SAGA**

Use SAGA (Substructure Index-based Approximate Graph Alignment) with the MiMI Plugin to compare and match selected nodes and edges to a database of known biological pathways.
1. Select a subset of a MiMI network in Cytoscape, with the following requirements:
   - Select at least 2, but no more than 50, gene nodes.
   - Select at least 1, but no more than 80, gene interaction edges.

2. Right-click any selected node and select **MiMI Plugin → SAGA → Do SAGA (Choose multiple nodes & edges).**

3. Select either **KEGG Human Pathways** or **All KEGG Pathways**.

4. For **Percentage of Matched Nodes**, specify the percentage of selected nodes that must match a known biological pathway for the subset of nodes to be considered a successful match with the pathway. The default is 10%.
5. Click **Query**. The results appear in a new browser window or tab.

The Query Result:

Result for the Query: MiMIPPlugin2SAGA

Total Execution Time (s): 0.030983

Number of Matches: 4 (excluding self matches)

Matches Overview:

<table>
<thead>
<tr>
<th>Match No.</th>
<th>Match Graph Name (#Nodes, #Edges)</th>
<th>Graph Distance</th>
<th>Matching Nodes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Match #1</td>
<td>path:hsa04610 (50, 67) [Complement and coagulation cascades]</td>
<td>21.00</td>
<td>3 out of 8</td>
</tr>
<tr>
<td>Match #2</td>
<td>path:hsa04620 (62, 79) [Toll-like receptor signaling pathway]</td>
<td>24.00</td>
<td>2 out of 8</td>
</tr>
<tr>
<td>Match #3</td>
<td>path:hsa04012 (53, 45) [Glioblastoma signaling pathway]</td>
<td>25.00</td>
<td>2 out of 8</td>
</tr>
<tr>
<td>Match #4</td>
<td>path:hsa04630 (22, 27) [Jak-STAT signaling pathway]</td>
<td>25.00</td>
<td>2 out of 8</td>
</tr>
</tbody>
</table>

6. Click a link in the **Match No.** column to view a visual representation of the match between selected network nodes in your query and the matching graph.

7. To view the complete KEGG pathway that was matched, click the **[Link to KEGG Picture]** link.
WORKING WITH NETWORKS

Expanding a network on a gene node

You can expand the current network to the nearest neighbors of a gene node.

*Original network:*

1. Double-click a gene node (the *expansion seed*).

2. If the number of additional gene nodes exceeds 30, Cytoscape displays the number and asks if you want to continue. Click *Yes* or *No*.

3. If expansion continues:
   - The network expands, adding the nearest neighbors of the expansion seed.
   - The network view may be redrawn, and the expansion seed may appear in a different location.
   - On the **Network** tab in the Control Panel, the number of nodes and edges is updated.
Expanded network:

Symbols appearing in a network expansion:

<table>
<thead>
<tr>
<th>Expansion seed node (selected)</th>
<th>Expansion seed node (unselected)</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="ITGAM" /></td>
<td><img src="image" alt="ITGAM" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Expansion neighbor (selected)</th>
<th>Expansion neighbor (unselected)</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="AUP1" /></td>
<td><img src="image" alt="AUP1" /></td>
</tr>
</tbody>
</table>
Collapsing an expanded gene node

To collapse an expanded gene node, double-click the expansion seed. The network returns to its original state.

**Note:** For best results, if you have further expanded a network by expanding on an expansion neighbor, collapse the nodes in the reverse order in which you expanded them.

Destroying a network

To destroy a network you no longer need:

1. Make sure you want to destroy the network:
   - Cytoscape will not ask you to confirm the deletion.
   - Destroying the network is irreversible.
   - **Note:** If you want to destroy a network view without destroying the network itself, use **Destroy View** instead of **Destroy Network**. See the *Cytoscape User Manual* for more information.

2. On the **Network** tab in the Control Panel, right-click on the network you want to destroy (the network does not need to be selected), and select **Destroy Network**.

SAVING AND REOPENING A SESSION

Saving a session

To save a Cytoscape session containing one or more MiMI Plugin networks:

1. From the Cytoscape menu, select **File → Save** (or **Save As**).
2. Browse to a location for the session file.
3. Name the file.
4. Click **Save**.

Reopening a session

To reopen a saved session containing MiMI Plugin data:

1. From the Cytoscape menu, select **File → Open**.
2. Navigate to the file location.
3. Select the file.
4. Click **Open**.

5. After Cytoscape reports that the session file was successfully loaded, click **Close**.

**USING MIMI PLUGIN-SPECIFIC FEATURES IN CYTOSCAPE**

**Restoring the MiMI visual style**

You may need to restore the MiMI visual style after using a different plugin that uses its own style.

*Network after using the MCODE plugin with MCODE visual style*

```plaintext
1. In the Cytoscape Control Panel, click the **VizMapper™** tab. You may need to use the scroll arrows at the top of the Control Panel to see the tab.

2. For **Current Visual Style**, select **MiMI**:
```
```
3. The MiMI visual style is restored:

*Network after resetting the MiMI visual style*

---

**Annotations**

You can add public or private annotations to a gene node or gene interaction edge. For more information:

- See [Adding your own node/edge annotation](https://ncibi.org) in the MiMI Plugin tutorial on the NCIBI website.

- Explore on your own by right-clicking a node or edge and selecting **MiMI Plugin → User Annotation → Add Your Annotation**. (You will need to sign up and then sign in to create your own annotations.)
Accessing the MiMI Plugin legend

In the Cytoscape Control Panel, click the **MiMI Legend** tab. You may need to use the scroll arrows at the top of the Control Panel to see the tab.

![MiMI Legend tab](image)

**Note:** If you open a saved Cytoscape session, the **MiMI Legend** tab does not appear in the Control Panel until you use the MiMI Plugin to enter gene information in a new query.
MiMI Plugin selection behavior

When you select nodes and edges, they are highlighted in the network view, and the attributes of the selected nodes or edges are displayed on the Node Attribute Browser or Edge Attribute Browser tab in the Cytoscape Data Panel: